Build --tx --send HANGS, NEVER RETURNS with the large-block-fix

Last week before I tried the v 1.0.1, I rebuilt with the large-block-fix for smart-contract and for pkg,
but now unfortunately, build --tx --send HANGS, NEVER RETURNS.
But build --tx works fine.

I tried a lot of things but no luck.

One strange aspect is that the daemon found only 3 peers and the client sync --nostop found only 1 peer so far.
I ran sync --nostop for over 90 minutes but still only 1 peer found.
So the build --tx --send is done with only 1 peer and it hangs.
Unlike previous iterations of this problem,
the logs look clean - I do not see any unusual error messages.
In the client log, I can see that it Broadcast the new C1 transaction.
But in the daemon log, there is no indication of that transaction.

Any ideas?

I am not sure about the peer issue. Nothing has change with the software related to that.

Are you sure your RPC is working and configured properly? I think it relies more on that for transaction broadcast than it used to.

OH I checked the latest 1.0.1 cli.dev.env example and I see that now it requires
export RPC_HOST=
export RPC_USERNAME=
export RCP_PASSWORD=

I have not put them in all my cli.dev.env’s so far.

Is this recently a new requirement to have in the cli.dev.env?

So that was probably the issue why the send was hanging.

Thanks.